rpm.spec 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. %define RELEASE 1
  2. %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
  3. %define prefix /usr
  4. Name: %NAME
  5. Summary: A C++ application logging library
  6. Version: %VERSION
  7. Release: %rel
  8. Group: Development/Libraries
  9. URL: http://github.com/google/glog
  10. License: BSD
  11. Vendor: Google
  12. Packager: Google Inc. <opensource@google.com>
  13. Source: https://github.com/google/glog/archive/v%{VERSION}.tar.gz
  14. Distribution: Redhat 7 and above.
  15. Buildroot: %{_tmppath}/%{name}-root
  16. Prefix: %prefix
  17. %description
  18. The %name package contains a library that implements application-level
  19. logging. This library provides logging APIs based on C++-style
  20. streams and various helper macros.
  21. %package devel
  22. Summary: A C++ application logging library
  23. Group: Development/Libraries
  24. Requires: %{NAME} = %{VERSION}
  25. %description devel
  26. The %name-devel package contains static and debug libraries and header
  27. files for developing applications that use the %name package.
  28. %changelog
  29. * Wed Mar 26 2008 <opensource@google.com>
  30. - First draft
  31. %prep
  32. %setup
  33. %build
  34. ./configure
  35. make prefix=%prefix
  36. %install
  37. rm -rf $RPM_BUILD_ROOT
  38. make prefix=$RPM_BUILD_ROOT%{prefix} install
  39. %clean
  40. rm -rf $RPM_BUILD_ROOT
  41. %files
  42. %defattr(-,root,root)
  43. ## Mark all installed files within /usr/share/doc/{package name} as
  44. ## documentation. This depends on the following two lines appearing in
  45. ## Makefile.am:
  46. ## docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
  47. ## dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README
  48. %docdir %{prefix}/share/doc/%{NAME}-%{VERSION}
  49. %{prefix}/share/doc/%{NAME}-%{VERSION}/*
  50. %{prefix}/lib/libglog.so.0
  51. %{prefix}/lib/libglog.so.0.0.0
  52. %files devel
  53. %defattr(-,root,root)
  54. %{prefix}/include/glog
  55. %{prefix}/lib/libglog.a
  56. %{prefix}/lib/libglog.la
  57. %{prefix}/lib/libglog.so
  58. %{prefix}/lib/pkgconfig/libglog.pc